Implosion in App Store

Requires iOS 6.0 or later. Compatible with iPhone 4S, iPhone 5, iPhone 5c, iPhone 5S, iPhone 6, iPhone 6 Plus, iPhone 6S, iPhone 6S Plus, iPhone SE (1st generation), iPhone 7, iPhone 7 Plus, iPhone 8, iPhone 8 Plus, iPhone X, iPhone XS, iPhone XS Max, iPhone XR, iPhone 11, iPhone 11 Pro, iPhone 11 Pro Max, iPhone SE (2. 1st generation), iPad Wi-Fi (3rd generation), iPad (3rd generation) Wi-Fi + Cellular, iPad Wi-Fi (4th generation), iPad (4th. 1st generation) Wi-Fi + Cellular, iPad mini Wi-Fi, iPad mini Wi-Fi + Cellular, iPad Air, iPad Air Wi-Fi + Cellular, iPad mini 2, iPad mini 2 Wi-Fi + Cellular, iPad Air 2, iPad Air 2 Wi-Fi + Cellular, iPad mini 3, iPad mini 3 Wi-Fi + Cellular, iPad mini 4, iPad mini 4 Wi-Fi + Cellular, iPad Pro 12.9″, iPad Pro 12.9″ Wi-Fi + Cellular, iPad Pro 9.7″, iPad Pro 9.7″ Wi-Fi + Cellular, iPad (5. 1st generation), iPad (5th. 1st generation) Wi-Fi + Cellular, iPad Pro 12.9″ (2nd generation), iPad Pro 12.9″ (2nd generation) Wi-Fi + Cellular, iPad Pro 10.5″, iPad Pro 10.5″ Wi-Fi + Cellular, iPad (6th generation), iPad Wi-Fi + Cellular (6th. 6th generation), iPad Pro 11″, iPad Pro 11″ Wi-Fi + Cellular, iPad Pro 12.9″ (3rd generation), iPad Pro 12.9″ (3rd generation) Wi-Fi + Cellular, iPad mini (5th generation), iPad mini (5th generation) 5th generation) Wi-Fi + Cellular, iPad Air (3rd generation), iPad Air (3rd generation) Wi-Fi + Cellular, iPad (7th generation), iPad (7th generation) Wi-Fi + Cellular, iPad Pro 11″ (2nd generation), iPad Pro 11″ (2nd) 2nd generation) Wi-Fi + Cellular, 12.9″ iPad Pro (4th generation), 12.9″ iPad Pro (4th generation) Wi-Fi + Cellular, iPod touch (5th generation), iPod touch (6th generation), and iPod touch (7th generation).

Similar Posts